XVG节点草稿



  • sudo apt-get install build-essential libtool autotools-dev automake pkg-config bsdmainutils python3构建要求
    sudo apt-get install libssl-dev libevent-dev libboost-all-dev自编译构建依赖
    sudo apt-get install zlib1g-dev libseccomp-dev libcap-dev libncap-dev 这些是使用Tor构建所必需的

    钱包需要BerkeleyDB。
    仅适用于Ubuntu: 您可以使用以下命令添加存储库并进行安装:
    sudo apt-get install software-properties-common
    sudo add-apt-repository ppa:bitcoin/bitcoin
    sudo apt-get update
    sudo apt-get install libdb4.8-dev libdb4.8++-dev
    Ubuntu和Debian有自己的libdb-dev和libdb ++ - dev软件包,但这些软件包将安装BerkeleyDB 5.1或更高版本。这将破坏二进制钱包与分布式可执行文件的兼容性,这些可执行文件基于BerkeleyDB 4.8。如果您不关心钱包兼容性,请--with-incompatible-bdb转到配置

    可选(请参阅--with-miniupnpc和--enable-upnp-default):
    sudo apt-get install libminiupnpc-dev

    ZMQ依赖项(提供ZMQ API):
    sudo apt-get install libzmq3-dev

    GUI依赖项:
    如果要构建Verge-qt,请确保安装了Qt开发所需的软件包。Qt 5是构建GUI的必要条件。没有GUI传递的构建--without-gui。

    要使用Qt 5构建,您需要以下内容:
    sudo apt-get install libqt5gui5 libqt5core5a libqt5dbus5 qttools5-dev qttools5-dev-tools libprotobuf-dev protobuf-compiler

    (可选)可以安装:
    sudo apt-get install libqrencode-dev
    安装完成后,将通过configure找到它们,默认情况下将构建Verge-qt可执行文件。

    git clone https://github.com/vergecurrency/VERGE.git 在~/VERGE
    cd VERGE
    ./autogen.sh
    ./configure --disable-wallet --without-gui --without-miniupnpc 禁用钱包
    make 编译 大小有2.4G
    ~/VERGE/src$ ./verged -h查看帮助
    ~/VERGE/src$ ./verged创建.VERGE隐藏目录ls -al
    vim .VERGE/VERGE.conf 示例Verge Mainnet配置 https://github.com/vergecurrency/bitcore
    whitelist=127.0.0.1
    txindex=0
    listen=1
    server=1
    upnp=1

    Make sure port & rpcport matches the

    bitcore.config.json ports for XVG mainnet

    if using Verge Core v5+ prefix

    [main]

    port=21102
    rpcport=20102
    rpcallowip=127.0.0.1

    rpcuser=fj
    rpcpassword=fj

    ./path/to/verged
    后台运行nohup ./verged & 输出的nohup.out空,在cd ~/.VERGE.debug.log里。
    https://verge-blockchain.info/
    查看同步信息cd ~/.VERGE
    tail -f debug.log



  • @tvrosinaXVG节点草稿 中说:

    sudo apt-get install build-essential libtool autotools-dev automake pkg-config bsdmainutils python3构建要求
    sudo apt-get install libssl-dev libevent-dev libboost-all-dev自编译构建依赖
    sudo apt-get install zlib1g-dev libseccomp-dev libcap-dev libncap-dev 这些是使用Tor构建所必需的

    钱包需要BerkeleyDB。
    仅适用于Ubuntu: 您可以使用以下命令添加存储库并进行安装:
    sudo apt-get install software-properties-common
    sudo add-apt-repository ppa:bitcoin/bitcoin
    sudo apt-get update
    sudo apt-get install libdb4.8-dev libdb4.8++-dev
    Ubuntu和Debian有自己的libdb-dev和libdb ++ - dev软件包,但这些软件包将安装BerkeleyDB 5.1或更高版本。这将破坏二进制钱包与分布式可执行文件的兼容性,这些可执行文件基于BerkeleyDB 4.8。如果您不关心钱包兼容性,请--with-incompatible-bdb转到配置

    可选(请参阅--with-miniupnpc和--enable-upnp-default):
    sudo apt-get install libminiupnpc-dev

    ZMQ依赖项(提供ZMQ API):
    sudo apt-get install libzmq3-dev

    GUI依赖项:
    如果要构建Verge-qt,请确保安装了Qt开发所需的软件包。Qt 5是构建GUI的必要条件。没有GUI传递的构建--without-gui。

    要使用Qt 5构建,您需要以下内容:
    sudo apt-get install libqt5gui5 libqt5core5a libqt5dbus5 qttools5-dev qttools5-dev-tools libprotobuf-dev protobuf-compiler

    (可选)可以安装:
    sudo apt-get install libqrencode-dev
    安装完成后,将通过configure找到它们,默认情况下将构建Verge-qt可执行文件。

    git clone https://github.com/vergecurrency/VERGE.git 在~/VERGE
    cd VERGE
    ./autogen.sh
    ./configure --disable-wallet --without-gui --without-miniupnpc 禁用钱包
    make 编译 大小有2.4G
    ~/VERGE/src$ ./verged -h查看帮助
    ~/VERGE/src$ ./verged创建.VERGE隐藏目录ls -al
    vim .VERGE/VERGE.conf 示例Verge Mainnet配置 https://github.com/vergecurrency/bitcore
    whitelist=127.0.0.1
    txindex=0
    listen=1
    server=1
    upnp=1

    Make sure port & rpcport matches the

    bitcore.config.json ports for XVG mainnet

    if using Verge Core v5+ prefix

    [main]

    port=21102
    rpcport=20102
    rpcallowip=127.0.0.1

    rpcuser=fj
    rpcpassword=fj

    ./path/to/verged
    后台运行nohup ./verged & 输出的nohup.out空,在cd ~/.VERGE.debug.log里。
    https://verge-blockchain.info/
    查看同步信息cd ~/.VERGE
    tail -f debug.log

    sudo apt-get update && sudo apt-get -y install git libcanberra-gtk-module lynx unzip libdb4.8-dev libdb4.8++-dev build-essential libtool autotools-dev automake pkg-config libssl-dev libevent-dev bsdmainutils git libboost-all-dev libminiupnpc-dev libqt5gui5 libqt5core5a libqt5dbus5 libevent-dev qttools5-dev qttools5-dev-tools libprotobuf-dev protobuf-compiler libqrencode-dev libseccomp-dev libcap-dev



  • This post is deleted!